跳转到内容
无痕工具库 无痕工具库

Hostinger 连接 Microsoft SQL Server(ODBC)教程

步骤 1 — 检查 /etc/odbcinst.ini 文件

检查 /etc/odbcinst.ini 文件,确保其中包含与下面类似的信息。你可以通过 SSH 进行检查。使用命令 cat /etc/odbcinst.ini:

[FreeTDS]
Description = ODBC for FreeTDS
Driver = /usr/lib64/libtdsodbc.so
Setup = /usr/lib64/libtdsS.so.2
Driver64 = /usr/lib64/libtdsodbc.so
Setup64 = /usr/lib64/libtdsS.so.2
FileUsage = 1

你不需要对该文件进行任何修改,只需确认它存在且包含数据。如果找不到该文件或文件为空,请 联系我们。

步骤 2 — 创建 .odbc.ini 文件

进入你网站的 文件管理器,选择 访问主机方案的所有文件 选项:

商业主机方案的文件管理器中访问所有站点文件的选项

这样你就会进入主机方案的根目录。在此处创建一个 .odbc.ini 文件:

Hostinger 文件管理器中创建 .odbc.ini,创建按钮已高亮显示

在文件中添加以下内容:

[mssql_odbc]
Description = MSSQL Server
Driver = FreeTDS
Database = username_databasename
Server = mssql.database.servername.tld
Port = 1433

按以下说明进行替换:

  1. username_database — 填入要使用的 SQL 服务器数据库名称
  2. mssql.database.servername.tld — 填入要连接的 服务器主机名或 IP 地址
  3. 1433 — 填入用于 MSSQL 连接的端口;仅当你的默认端口不是 1433 时才需要更改此数字

保存更改:

odbc.ini 文件编辑器,右上角的保存图标已高亮显示

步骤 3 — 检查必要的 PHP 扩展

确保在你网站的 PHP 配置设置 中启用了以下扩展:

  • odbc
  • pdo_odbc

步骤 4 — 测试连接

最后,使用以下代码行测试连接:

$dbh = new PDO("odbc:mssql_odbc", "%DB_USER%", "%DB_PASS%");

如果一切设置正确,连接将会成功。

如果系统提示需要安装 ODBC 驱动程序该怎么办

如果你收到以下错误:

This extension requires the Microsoft ODBC Driver for SQL Server.
Access the following URL to download the ODBC Driver for SQL Server for x64: https://go.microsoft.com/fwlink/?LinkId=163712

这说明你的脚本没有使用 PDO 函数。

目前,在 PHP 中只能使用 PDO 函数连接 SQL 服务器。其他扩展(如 sqlsrv 及类似扩展)将会失败,因为它们不使用 .odbc.ini 文件配置。