Hostinger 定时任务(cron)故障排查指南
虽然 cron 作业可以帮助你在服务器上自动执行任务,但它们有时可能会失败。以下是一些最常见的原因及其解决方法:
脚本无法正常运行
在**创建 cron 作业之前,建议先测试你的脚本,确保脚本在脱离自动调度的情况下也能正常运行。为此,你可以在网页浏览器中打开该文件(输入脚本文件的 URL),或通过 SSH 执行它,具体取决于你的脚本类型。如果脚本报错或无法运行,请检查代码。如果你无法自行解决问题,可能需要寻求开发者的帮助**。
请注意,输出为空并不一定意味着 cron 作业没有正常运行。大多数脚本没有默认输出,因此你可能需要**手动添加输出**。
路径或 URL 不正确
请仔细检查文件是否确实位于你用于设置 cron 作业的路径或 URL 上。在 Hostinger,所有文件路径都以 /home/ 开头。例如,如果你想执行位于域名 public_html 文件夹中的 script.php 文件,完整路径将类似于以下形式之一:
- /home/u12345678/domains/domain.tld/public_html/script.php
- /home/u12345678/public_html/script.php
你可以在 FTP Accounts(FTP 账户) 部分验证你的路径结构。
如果 cron 作业配置为通过 URL 而非文件路径打开文件,你可以通过**终端**使用 curl 命令测试其是否有效:
curl -v 'https://domain.tld/path/to/script.php'请将 URL 替换为你自己的 URL、路径和文件名。
使用了特殊字符
在 Hostinger 控制面板中创建 PHP cron 作业时不支持特殊字符,例如 “>/dev/null 2>&1”。如果你的 cron 作业需要使用特殊字符,则需要创建一个 .sh 文件,并设置一个自定义 cron 作业来执行它。只需按照以下指南操作即可:如何在 Hostinger 设置带特殊字符的 cron 作业。
资源使用量超限
如果服务器超出资源限制(例如 CPU、内存或磁盘空间),cron 作业可能会失败。当达到系统资源限制时,cron 作业可能会被中断,或完全无法运行。这种情况可能发生在系统超载时,导致 cron 作业被跳过或未按计划执行。
要检查主机方案资源的使用情况,请前往 Websites(网站) 页面,并点击相应主机方案中所添加网站旁边的 Dashboard(控制面板)。接着,在侧边栏中搜索 Resources Usage(资源使用量)。如果你发现使用量已超限,请参考以下指南:在 Hostinger 中主机方案达到限制时该怎么办。