跳转到内容
无痕工具库 无痕工具库

Hostinger 创建迁移请求常见错误解决方法详解

在创建迁移请求时,你可能会遇到一些常见错误。别担心——本指南将逐步带你解决这些问题。

域名指向了 Hostinger 的名称服务器

错误信息:“你只能迁移托管在其他服务商处的网站。”

Hostinger 迁移请求错误信息:只能迁移托管在其他服务商处的网站

错误原因

如果域名指向了 Hostinger 的名称服务器,就会出现此错误。

解决方法

你需要将名称服务器改回原主机服务商的名称服务器。请注意,DNS 传播需要 24 小时才能完成。

登录 URL 无法访问

错误信息:“WordPress 控制面板的登录 URL 不正确。”

Hostinger 迁移请求错误:WordPress 管理登录 URL 不正确,粉色警告框高亮显示

错误原因

如果登录 URL 显示错误(如 404 错误、503 错误等),就会出现此错误。

解决方法

  1. 确保你的域名指向原主机服务商的服务器。
  2. 域名指向原主机服务器后,检查登录 URL 是否可以访问。如果仍然无法访问,请联系原主机服务商的技术支持来排查该错误。

一切确认无误后,请再次尝试提交迁移请求。

登录凭据不正确

错误信息:“你提供的后台管理面板登录凭据不正确。”

Hostinger WordPress 迁移表单显示管理登录 URL 错误

错误原因

在以下情况下会出现此错误:

  • 用户名或密码不正确。
  • 启用了双因素身份验证(2FA)、CAPTCHA 或验证提示,从而阻止了登录过程。

解决方法

  1. 仔细核对用户名和密码,确保其正确无误。
  2. 在创建迁移请求期间,临时禁用 2FA 或 CAPTCHA。

你可以参考以下指南了解如何禁用它们:

一切确认无误后,请再次尝试提交迁移请求。

特殊情况:使用自定义登录 URL 并启用防机器人或 CAPTCHA 保护

如果你使用的是自定义登录 URL(而非默认的 /wp-admin),并且在当前主机(例如 SiteGround)上启用了防机器人或 CAPTCHA 保护,那么即使用户名和密码正确,迁移系统也可能无法验证 WordPress 凭据。因为在进行身份验证之前,该保护机制就会阻止我们的服务器访问登录页面。

解决方法

  1. 在当前主机上临时禁用防机器人或 CAPTCHA 保护,然后重新提交迁移请求。
  2. 如果无法禁用,你可以改选**上传备份(Upload backup)**选项。

用户需要管理员角色

错误信息:“该用户需要管理员(Administrator)角色。”

WordPress 登录界面显示错误信息:所选用户需要管理员角色

错误原因

如果你使用的用户名不具备管理员角色,就会出现此错误。创建迁移请求需要管理员角色。

解决方法

  1. 进入 WordPress 控制面板 → 用户(Users)→ 所有用户(All Users)。
  2. 找到该用户名并点击编辑(Edit)。
  3. 向下滚动到“角色(Role)”部分。
  4. 将角色更改为管理员(Administrator),然后点击保存更改(Save Changes)。
  5. 接下来,再次尝试提交迁移请求。

按照以上步骤操作,你就可以轻松解决创建迁移请求时可能出现的最常见错误。请仔细核对登录信息,确保安装了正确的插件,并确认你的用户角色已设置为管理员,以避免任何问题。