跳转到内容
无痕工具库 无痕工具库

Hostinger 网站迁移请求被拒绝怎么办?解决方法详解

网站迁移至 Hostinger 的请求可能因多种原因而无法完成。这些问题通常需要你先采取行动,迁移才能顺利完成。

迁移服务仅适用于将网站从其他主机服务商迁移至 Hostinger。已托管在 Hostinger 的网站不符合此流程的条件。如果是这种情况,则无需提交或修改迁移请求,你可以手动将网站迁移到其他主机方案或其他 Hostinger 账户。

常见问题

如果你的迁移请求被标记为已拒绝(Rejected),请查看迁移团队留下的消息。以下是请求无法完成的常见原因及其解决方法:

问题解决方案
登录信息不正确仔细检查网站登录 URL 和凭据(管理员用户名和密码)是否正确。
原主机服务商开启了双重身份验证在迁移完成之前,暂时在原主机服务商处禁用 2FA。
域名已指向 Hostinger更新域名的域名服务器或 IP 地址,使其与原主机服务商的记录一致,然后等待 DNS 传播完成。
磁盘空间不足,无法创建备份删除原主机账户中不必要的文件,或直接在 Hostinger 控制面板中上传备份。
插件安装失败向原主机服务商查询错误原因并修复,然后重试迁移。
提供的备份存在问题确保备份包含所有网站文件和数据库。以受支持的格式(文件为 .tar.gz、.zip、.rar、.tar,数据库为 .sql)重新上传完整备份。
不支持的 CMS基于不受支持的平台或技术构建的网站(例如使用其他服务商专有建站工具创建的网站、仅在云服务器(VPS)上受支持的自定义网站)无法自动迁移。你需要手动迁移或重新构建网站。
账户被暂停恢复对旧主机账户的访问权限,或准备一份完整备份(文件和数据库)。
域名已过期在原主机服务商处续费域名,或使用完整备份(文件和数据库)。
多站点(Multisite)我们的迁移服务不支持 WordPress 多站点迁移。你仍可以在 Hostinger 托管多站点,只需自行设置 WordPress 多站点并从备份恢复网站即可迁移内容。
wp-admin 使用自定义 URL如果你的 WordPress 登录页面使用自定义 URL,请务必将其作为登录链接提供。或者,使用完整备份(文件和数据库)。
数据库大小超出方案限制通过优化数据库来减小其大小。
原主机仅支持 FTP不支持仅通过 FTP 进行迁移。请改为准备完整备份(文件和数据库)。
文件未压缩(SFTP/FTP)将网站文件和数据库压缩为单个压缩包(.tar.gz、.zip、.rar、.tar),以避免数据缺失。
未找到源域名核实源域名信息是否正确。
服务器连接被关闭联系原主机服务商,确保服务器可访问且能够创建备份。

问题解决后:

  • 如果解决方法是更正信息(例如登录凭据、DNS 或服务器访问权限),你可以使用更新后的信息创建新的迁移请求。
  • 如果你提交的是 WordPress 凭据但该方法不可行,可以改为提供 cPanel 凭据。同样,如果 cPanel 凭据不可用,请尝试使用 WordPress 凭据。
  • 如果两种方法都行不通,请下载网站的完整备份(文件和数据库),并使用**上传备份文件(Upload backup files)**选项创建新的迁移请求。

提交新请求或编辑被拒绝的请求后,请查看如何检查网站迁移状态以跟踪进度。